$re = '/(Icon=).*\/(.*)(.png)/x';
$str = 'Icon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.png';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;