// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(Icon=).*\/(.*)(.png)").unwrap();
let string = "Icon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.pngIcon=/usr/share/icons/Moka/256x256/apps/virtualbox.png";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}