#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\+7\(\d{3}\)\d{3}-\d{2}-\d{2}"
Local $sString = "+7(912)123-45-67" & @CRLF & _
"+7 (999) 999 - 99 - 99" & @CRLF & _
"+7(999)999-99-99" & @CRLF & _
"+7(aaa)bbb-cc-dd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")