re = /\+7\(\d{3}\)\d{3}-\d{2}-\d{2}/
str = '+7(912)123-45-67
+7 (999) 999 - 99 - 99
+7(999)999-99-99
+7(aaa)bbb-cc-dd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end