// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\+7\(\d{3}\)\d{3}-\d{2}-\d{2}").unwrap();
let string = "+7(912)123-45-67
+7 (999) 999 - 99 - 99
+7(999)999-99-99
+7(aaa)bbb-cc-dd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}