package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+7\(\d{3}\)\d{3}-\d{2}-\d{2}`)
var str = `+7(912)123-45-67
+7 (999) 999 - 99 - 99
+7(999)999-99-99
+7(aaa)bbb-cc-dd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}