const regex = /\+7\(\d{3}\)\d{3}-\d{2}-\d{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+7\\(\\d{3}\\)\\d{3}-\\d{2}-\\d{2}', 'g')
const str = `+7(912)123-45-67
+7 (999) 999 - 99 - 99
+7(999)999-99-99
+7(aaa)bbb-cc-dd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}