$re = '/(?!^)(?<!\d[.A-Z])(?<!\d[A-Z]\.)\b(?=\d+(?:[a-zA-Z]|\.)\s+\p{Lu})/';
$str = '5. SCOPE This document outlines what to do in case of emergency landing (ignore for non-emergency landings) on tarmac. 6. WHEELS Never land on tarmac. Unless you have lowered the plane wheel mechanism. 6.1 Lower the wheel mechanism using the 2 Switches labelled \'wheel mechanism\'. 7A WARNING 7A.1 Do not forget to warn passengers.
';
$subst = "\n-----------\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;