import Foundation
let pattern = #"(?!^)(?<!\d[.A-Z])(?<!\d[A-Z]\.)\b(?=\d+(?:[a-zA-Z]|\.)\s+\p{Lu})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
5. SCOPE This document outlines what to do in case of emergency landing (ignore for non-emergency landings) on tarmac. 6. WHEELS Never land on tarmac. Unless you have lowered the plane wheel mechanism. 6.1 Lower the wheel mechanism using the 2 Switches labelled 'wheel mechanism'. 7A WARNING 7A.1 Do not forget to warn passengers.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n-----------\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)