using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\(\[(?:(?!\(\[|\]\)).)*TEST(?:(?!\(\[|\]\)).)*\]\))(?=.*TEST).*";
string input = @"TEST
this is my ([TEST
this is my TEST]) number 2
([bla]) TEST ([bla])
this is my ([TEST]) oops
this is my ([bla TEST bla])
this is my ([TEST TEST])
string without the tes* word
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}