import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\(\\[(?:(?!\\(\\[|\\]\\)).)*TEST(?:(?!\\(\\[|\\]\\)).)*\\]\\))(?=.*TEST).*";
final String string = "TEST\n"
+ "this is my ([TEST\n"
+ "this is my TEST]) number 2\n"
+ "([bla]) TEST ([bla])\n\n"
+ "this is my ([TEST]) oops\n"
+ "this is my ([bla TEST bla])\n"
+ "this is my ([TEST TEST])\n"
+ "string without the tes* word\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}