re = /^(?!.*\(\[(?:(?!\(\[|\]\)).)*TEST(?:(?!\(\[|\]\)).)*\]\))(?=.*TEST).*/m
str = 'TEST
this is my ([TEST
this is my TEST]) number 2
([bla]) TEST ([bla])
this is my ([TEST]) oops
this is my ([bla TEST bla])
this is my ([TEST TEST])
string without the tes* word
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end