$re = '/^(?!.*\(\[(?:(?!\(\[|\]\)).)*TEST(?:(?!\(\[|\]\)).)*\]\))(?=.*TEST).*/m';
$str = 'TEST
this is my ([TEST
this is my TEST]) number 2
([bla]) TEST ([bla])
this is my ([TEST]) oops
this is my ([bla TEST bla])
this is my ([TEST TEST])
string without the tes* word
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);