import re
regex = re.compile(r"^(?!.*\(\[(?:(?!\(\[|\]\)).)*TEST(?:(?!\(\[|\]\)).)*\]\))(?=.*TEST).*", flags=re.MULTILINE)
test_str = ("TEST\n"
"this is my ([TEST\n"
"this is my TEST]) number 2\n"
"([bla]) TEST ([bla])\n\n"
"this is my ([TEST]) oops\n"
"this is my ([bla TEST bla])\n"
"this is my ([TEST TEST])\n"
"string without the tes* word\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")