using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\W_]{2,}";
string input = @"The rain in spain_stays
spain
The rain in $spain_stays$
The rain in $spain_stays
The rain in spain_stays*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}