package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\W_]{2,}`)
var str = `The rain in spain_stays
spain
The rain in $spain_stays$
The rain in $spain_stays
The rain in spain_stays*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}