re = /[^\W_]{2,}/m
str = 'The rain in spain_stays
spain
The rain in $spain_stays$
The rain in $spain_stays
The rain in spain_stays*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end