$re = '/[^\W_]{2,}/m';
$str = 'The rain in spain_stays
spain
The rain in $spain_stays$
The rain in $spain_stays
The rain in spain_stays*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);