#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*[.*]{2})[a-z0-9*_:-]+(?:\.[a-z0-9_:-]+)"
Local $sString = "this does not work libname.data" & @CRLF & _
"libname.data" & @CRLF & _
"libname.data;" & @CRLF & _
"libname.data(stuff)" & @CRLF & _
"libname.data(stuff);" & @CRLF & _
"libname.data (stuff)" & @CRLF & _
"libname.data(stuff);" & @CRLF & _
"libname.*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")