using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[.*]{2})[a-z0-9*_:-]+(?:\.[a-z0-9_:-]+)";
string input = @"this does not work libname.data
libname.data
libname.data;
libname.data(stuff)
libname.data(stuff);
libname.data (stuff)
libname.data(stuff);
libname.*";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}