const regex = /^(?!.*[.*]{2})[a-z0-9*_:-]+(?:\.[a-z0-9_:-]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[.*]{2})[a-z0-9*_:-]+(?:\\.[a-z0-9_:-]+)', 'gmi')
const str = `this does not work libname.data
libname.data
libname.data;
libname.data(stuff)
libname.data(stuff);
libname.data (stuff)
libname.data(stuff);
libname.*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}