re = /^(?!.*[.*]{2})[a-z0-9*_:-]+(?:\.[a-z0-9_:-]+)/mi
str = 'this does not work libname.data
libname.data
libname.data;
libname.data(stuff)
libname.data(stuff);
libname.data (stuff)
libname.data(stuff);
libname.*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end