$re = '/^(?!.*[.*]{2})[a-z0-9*_:-]+(?:\.[a-z0-9_:-]+)/mi';
$str = 'this does not work libname.data
libname.data
libname.data;
libname.data(stuff)
libname.data(stuff);
libname.data (stuff)
libname.data(stuff);
libname.*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);