#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "method=(\"(.+)(?<!\"))"
Local $sString = "<form method="get">" & @CRLF & _
"<form isform=1>" & @CRLF & _
"<form isform=1 method="get" some more data="more">" & @CRLF & _
"<form isform=1 method="">" & @CRLF & _
"<form isform=1 form="get">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")