using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"method=(\""(.+)(?<!\""))";
string input = @"<form method=""get"">
<form isform=1>
<form isform=1 method=""get"" some more data=""more"">
<form isform=1 method="">
<form isform=1 form=""get"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}