re = /method=(\"(.+)(?<!\"))/
str = '<form method="get">
<form isform=1>
<form isform=1 method="get" some more data="more">
<form isform=1 method="">
<form isform=1 form="get">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end