$re = '/method=(\"(.+)(?<!\"))/';
$str = '<form method="get">
<form isform=1>
<form isform=1 method="get" some more data="more">
<form isform=1 method="">
<form isform=1 form="get">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);