import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "method=(\\\"(.+)(?<!\\\"))";
final String string = "<form method=\"get\">\n"
+ "<form isform=1>\n"
+ "<form isform=1 method=\"get\" some more data=\"more\">\n"
+ "<form isform=1 method=\"\">\n"
+ "<form isform=1 form=\"get\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}