# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\d\/]+\s[\d:]+).*/$1/gm;t' <<< "5/25/2022 14:13:05
5/25/2022 13:21:07 EDT
5/25/2022 17:07:39 GMT+01:00"