import re
regex = re.compile(r"^([\d/]+\s[\d:]+).*", flags=re.MULTILINE)
test_str = ("5/25/2022 14:13:05\n"
"5/25/2022 13:21:07 EDT\n"
"5/25/2022 17:07:39 GMT+01:00")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)