#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\S\n]{2}(name_template_2:)((?:\n[^\S\n]{4}\S.*)+)"
Local $sString = "templates:" & @CRLF & _
" name_template:" & @CRLF & _
" description: test_description" & @CRLF & _
" define: yes" & @CRLF & _
" write: true" & @CRLF & _
" name_template_2:" & @CRLF & _
" description: test_description2" & @CRLF & _
" define: false" & @CRLF & _
" write: true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")