package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\S\n]{2}(name_template_2:)((?:\n[^\S\n]{4}\S.*)+)`)
var str = `templates:
name_template:
description: test_description
define: yes
write: true
name_template_2:
description: test_description2
define: false
write: true`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}