import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\S\\n]{2}(name_template_2:)((?:\\n[^\\S\\n]{4}\\S.*)+)";
final String string = "templates:\n"
+ " name_template:\n"
+ " description: test_description\n"
+ " define: yes\n"
+ " write: true\n"
+ " name_template_2:\n"
+ " description: test_description2\n"
+ " define: false\n"
+ " write: true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}