re = /^[^\S\n]{2}(name_template_2:)((?:\n[^\S\n]{4}\S.*)+)/m
str = 'templates:
name_template:
description: test_description
define: yes
write: true
name_template_2:
description: test_description2
define: false
write: true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end