# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^ESP\d{1,2}+\K.+//gm;t' <<< "ESP100
ESP10234234
ESP78hello
ESP10"