use strict;
my $str = 'ESP100
ESP10234234
ESP78hello
ESP10';
my $regex = qr/^ESP\d{1,2}+\K.+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";