import re
regex = re.compile(r"^ESP\d{1,2}+\K.+", flags=re.MULTILINE)
test_str = ("ESP100\n"
"ESP10234234\n"
"ESP78hello\n"
"ESP10")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)