using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ESP\d{1,2}+\K.+";
string substitution = @"";
string input = @"ESP100
ESP10234234
ESP78hello
ESP10";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}