$re = '/^ESP\d{1,2}+\K.+/m';
$str = 'ESP100
ESP10234234
ESP78hello
ESP10';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;