using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9-]";
string substitution = @"-";
string input = @"my/fancy/thing/test
three.four/now/i/am/two
basic/test
no-slashes
leave_my_underscores_alone
hyphens-and/slashes/and_underscores!plus+random~characters
THE KNIGHTS who say ""Ni!""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}