import Foundation
let pattern = #"[^a-zA-Z0-9-]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
my/fancy/thing/test
three.four/now/i/am/two
basic/test
no-slashes
leave_my_underscores_alone
hyphens-and/slashes/and_underscores!plus+random~characters
THE KNIGHTS who say "Ni!"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)