use strict;
my $str = 'my/fancy/thing/test
three.four/now/i/am/two
basic/test
no-slashes
leave_my_underscores_alone
hyphens-and/slashes/and_underscores!plus+random~characters
THE KNIGHTS who say "Ni!"';
my $regex = qr/[^a-zA-Z0-9-]/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";