import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9-]";
final String string = "my/fancy/thing/test\n"
+ "three.four/now/i/am/two\n"
+ "basic/test\n"
+ "no-slashes\n"
+ "leave_my_underscores_alone\n"
+ "hyphens-and/slashes/and_underscores!plus+random~characters\n"
+ "THE KNIGHTS who say \"Ni!\"";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}