#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^.*\r?\n){4}.*\K(,)$"
Local $sString = "('1234', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 12, 'hello')," & @CRLF & _
"('stuff', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 12, 'hello')," & @CRLF & _
"('stuff', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 12, 'hello')," & @CRLF & _
"('stuff', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 12, 'hello')," & @CRLF & _
"('stuff', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 12, 'hello')," & @CRLF & _
"('stuff', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 1234, '1234')," & @CRLF & _
"('1234', '1234', 12, 'hello')," & @CRLF & _
"('stuff', '1234', 1234, '1234'),"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)