import Foundation
let pattern = #"(?:^.*\r?\n){4}.*\K(,)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)