using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^.*\r?\n){4}.*\K(,)$";
string substitution = @"";
string input = @"('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),
('1234', '1234', 1234, '1234'),
('1234', '1234', 12, 'hello'),
('stuff', '1234', 1234, '1234'),";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}