$re = '/(?:^.*\r?\n){4}.*\K(,)$/m';
$str = '(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;