use strict;
my $str = '(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 1234, \'1234\'),
(\'1234\', \'1234\', 12, \'hello\'),
(\'stuff\', \'1234\', 1234, \'1234\'),';
my $regex = qr/(?:^.*\r?\n){4}.*\K(,)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";