using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[_\W]([a-df-z])(?![^_\W])";
string input = @"(1)/(2)+p_a*r*e*t*a*v+pi+\delta+\sigma
(1)/(2)+a_t*e*j*h*o+ \Delta
(1)/(2)+p_w
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}