import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[_\\W]([a-df-z])(?![^_\\W])";
final String string = "(1)/(2)+p_a*r*e*t*a*v+pi+\\delta+\\sigma\n\n"
+ "(1)/(2)+a_t*e*j*h*o+ \\Delta\n\n"
+ "(1)/(2)+p_w\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}